SkyCiv Documentation

Your guide to SkyCiv software - tutorials, how-to guides and technical articles

SkyCiv Structural 3D

  1. Home
  2. SkyCiv Structural 3D
  3. Getting Started
  4. Keyboard and Mouse Controls

Keyboard and Mouse Controls

Speed up your modeling with these handy keyboard/mouse controls, shortcuts, and tips

Keyboard Shortcuts

Here are just some of the keyboard shortcuts to make your data entry faster in SkyCiv Structural Analysis Software.

  • Ctrl + S: Save
  • Ctrl + N: New
  • Ctrl + Z: Undo
  • Ctrl + Y: Redo
  • Ctrl + A: Select All
  • Ctrl + D: Copy (Duplicate)
  • Ctrl + C: Copy (selected parts of the structure)
  • Ctrl + V: Paste (part of the structure copied)
  • N: Nodes
  • M: Members
  • E: Sections
  • O: Moments
  • P: Point Loads
  • D: Distributed Loads
  • U: Supports
  • B: Back Button / Exit Form
  • Delete: Delete members or plates after they are selected.
  • Esc: Cancel the current processing operation.

If at any point, you would like to see the list of shortcuts that we offer, go to Help > S3D Shortcuts and Tips as shown in the upper right-hand corner of the screen:

9

Here is a snapshot of the shortcuts and tips that help users expedite their modeling process:

10

Mouse Controls

SkyCiv has built out a range of features that make the modeling process extremely and fast and easy. One of these great sets of mouse click functions, that once used to, can allow users to mock up a model with a few clicks.

 
There are a range of tools that you can choose from. These can be accessed by clicking the pen icon  to launch the following great tools:

Click the pen icon  to access these different mouse controls

Default Tool

The default tool, denoted by the cross-hair mouse icon, has the following features:

  • Click + Drag between nodes to create a member. Hold a number to create a member with that number’s section ID:
  • With Plates menu open: Click between nodes to create a plate:
  • Hold CTRL + Drag to multi-select:
  • Rotating – Left click and drag to rotate your structure.
  • Panning – Right-click and drag to pan. Alternatively, use Shift + Left Click.
  • Zooming – Scroll mouse forward/back to zoom in/out of the model.
  • Select – Left click a member/node/plate/support/load.
  • Multi Select – Ctrl + Left Click.
  • Create Member – Left click starting node, drag to ending node, and release on ending node.
  • Click member, node, or any other object to view/edit/delete
  • Click member to view that result only (Post Solve Only)
  • Ctrl + Click: Multiple Object Select
  • Scroll + S: Scale Result/Loads

Note: If zooming not working on Chrome, try checking extensions

Quick Tips with Highlighting

Click and dragging in either direction will do something different!

Click and drag to the RIGHT will select anything that comes in contact with the box.

Click and drag to the LEFT will highlight anything that is entirely within the box. Both can be seen in the image below.

Draw Tool

  • Hover or click a node, this will become your Reference Node, from here you can use the Snap/Grid to plot a node:
  • With the Connect Member tickbox selected, you can both drop a node and connect the nodes as a member:
  • The Length box will auto display the length of the distance from the reference node (and hence the length of the member). At any point you can enter a length and hit Enter, or click, to apply that member length.
  • Enter a length and click the  (lock) icon to lock the length. Now you can create members fixed at this length.

Grab Tool

  • Click and drag a node to move it and snap it to a point of reference:

Right Click (Quick) Repairs

SkyCiv has introduced a couple of quick repair functions that allow users to easily detect and repair issues with your model. This is slightly different from SkyCiv’s Repair Model functionality which will repair your entire model. This is focused on your highlighted elements that the user can easily identify. For instance, two nodes closely together can be merged using the Merge Nodes feature. Here is the full list of quick repairs that are automatically detected by the software when you highlight and right-click parts of your structure.

Merge Nodes

Notice you have two nodes that are really close. It’s a fairly common problem and may cause disconnects in your model. Simply highlight the nodes (CTRL + CLICK & DRAG) then right-click and click Merge Nodes:

Intersecting Members

Sometimes members can be drawn over one another. Although difficult to notice, these can have disastrous effects on your model, as that model will have a double up and will overestimate the strength of that member (by a factor of 2). Simply highlight the overlapping members and right-click. The software will automatically detect the members as overlapping. To repair this simply clicks Merge Overlapping Members to merge the two members. It should look something like this:

Overlapping Members

Sometimes you want to split (and connect) members by their intersection. Remember, members are only connected if they have a common node. So if you have two intersecting members with no common node, they are not connected. Again, highlight the members and right-click to repair this and add a node at the point of their intersection. To do this, simply right-click and click Intersect Members. This will add a node at the intersection and separate the members into smaller elements:

Split Member

A useful tool that allows you to add a node and split the member based on some input. Members can be split based on intersecting nodes, intersecting members, number of sections, or at a location along with the member:

Have any other issues you’d like to have added to this list? Let us know at [email protected]

Watch the Video Tutorial on the Right Click Functionality in SkyCiv 3D Structural Analysis Software



 

 

 

Copy and Paste

Sometimes, there are parts of the structure that repeat at different locations and the duplicate functionality is not enough for speeding up the process. Having the possibility of easily copying and pasting parts of the structure to the same model or to a new one can help to save a lot of time during modeling. The copy and paste functionality works pretty similarly to how it works in a text editor, the first step is to select what to copy and hit Ctrl+C (⌘ + C in Mac), then decide and select the place where it is going to be pasted, and finally hit Ctrl+V (⌘ + V in Mac) to paste it to the desired location. When using Ctrl+C (⌘ + C in Mac), the software will automatically pick the reference point (the closest to the origin), alternatively, hitting Ctrl+Shift+C (⌘ + Shift + C in Mac) will wait for the user to select the reference node on the screen.

Copying the model as text

Given that the model of the structure in S3D is represented in the background by a JSON object, once Ctrl+C (⌘ + C in Mac) the software will write the representation of the selected model in JSON format to the clipboard. It is possible to paste that information to any text editor, either for developing purposes or to quickly edit the model by searching and replacing some text.

SkyCiv S3D copy and paste a model to a text editor

Copying parts of a model to the same model

If some parts of the model need to be copied to some other location, the following steps are required:

Using Ctrl+C (⌘ + C in Mac) – Automatic reference point

  1. Drag-select the parts of the model to copy (nodes, members, supports, loads, etc…). If there are some parts of the selection you want to exclude, right-click and go to “Filter Selection”
  2. Hit Ctrl + C. An alert should pop up telling that the structure was successfully copied to the clipboard and also the reference node’s ID.
  3. Along with the alert, a bubble will appear around the reference node in the model.
  4. Let the software know where to paste the copied structure. For this, there are two options:
    Select a node in the model that will match the location of the reference node once the structure is pasted, or
    Do not select anything and type a coordinate where the reference node should be once the structure is paste
  5. Hit Ctrl + V. The structure will be placed at the location selected in the previous step
    SkyCiv S3D copy and paste parts of the structure
  6. If the changes are not as desired, it is always possible to Undo them, simply hit Ctrl+Z or go to Edit > Undo

Using Ctrl+Shift+C (⌘ + Shift + C in Mac) – Reference point selection on screen

  1. Drag-select the parts of the model to copy (nodes, members, supports, loads, etc…). If there are some parts of the selection you want to exclude, right-click and go to “Filter Selection”
  2. Hit Ctrl + Shift + C. An alert should pop up telling that the structure was successfully copied to the clipboard and also the reference node’s ID.
  3. Along with the alert, a bubble will appear around the reference node in the model.
  4. Let the software know where to paste the copied structure. For this, there are two options:
    Select a node in the model that will match the location of the reference node once the structure is pasted, or
    Do not select anything and type a coordinate where the reference node should be once the structure is paste
  5. Hit Ctrl + V. The structure will be placed at the location selected in the previous step
    SkyCiv S3D copy and paste parts of the structure
  6. If the changes are not as desired, it is always possible to Undo them, simply hit Ctrl+Z or go to Edit > Undo

Copying parts of a model to a new model

If a model or parts of it need to be used in a new model, there is no need to “save as”, simply select the parts of the structure to copy, hit Ctrl + C then open a new model in another tab or window and hit Ctrl + V there to paste the structure.

Was this article helpful to you?
Yes No

How can we help?

Go to Top