SkyCiv文档

您的SkyCiv软件指南 - 教程, 使用指南和技术文章

SkyCiv结构3D

  1. SkyCiv结构3D
  2. 入门
  3. 键盘和鼠标控件

键盘和鼠标控件

使用这些方便的键盘/鼠标控件加速您的建模, 捷径, 和提示

键盘快捷键

Here are just some of the keyboard shortcuts to make your data entry faster in SkyCiv Structural Analysis Software.

  • Ctrl键 + 小号:
  • Ctrl键 + ñ:
  • Ctrl键 + 与: 撤消
  • Ctrl键 + 和: 重做
  • Ctrl键 + 一个: 全选
  • Ctrl键 + d: 重复 (复制)
  • Ctrl键 + C: 重复 (结构的选定部分)
  • Ctrl键 + V: 粘贴 (部分结构被复制)
  • ñ: 节点数
  • 中号: 会员
  • Ë: 栏目
  • Ø: 片刻
  • P: 点载荷
  • d: 分布式负载
  • ü: 支持
  • 乙: 返回键 / 退出表格
  • 删除: 成员或板块被选中后删除.
  • Esc键: 取消当前处理操作.

如果在任何时候, 您想查看我们提供的快捷方式列表, 去 帮助 > S3D 快捷方式和技巧 如屏幕右上角所示:

9

以下是帮助用户加快建模过程的快捷方式和技巧的快照:

10

鼠标控制

SkyCiv 已经构建了一系列功能,使建模过程极其快速和简单. 这些出色的鼠标单击功能之一, 曾经的, 可以让用户通过几次点击来模拟模型.

有多种工具可供您选择. These can be accessed by clicking the pen icon to launch the following great tools:

Click the pen icon to access these different mouse controls

默认工具

默认工具, denoted by the cross-hair mouse icon, has the following features:

  • 请点击 + Drag between nodes to create a member. Hold a number to create a member with that number’s section ID:
  • 板块 menu open: Click between nodes to create a plate:
  • 按住 CTRL + Drag to multi-select:
  • RotatingLeft click and drag to rotate your structure.
  • PanningRight-click and drag to pan. 或者, use Shift + Left Click.
  • ZoomingScroll mouse forward/back to zoom in/out of the model.
  • 选择 – Left click a member/node/plate/support/load.
  • Multi Select – Ctrl键 + Left Click.
  • Create MemberLeft click starting node, 拖到结束节点, 并在结束节点上释放.
  • 点击会员, 节点, 或任何其他要查看/编辑/删除的对象
  • 单击成员以仅查看该结果 (仅发布解决)
  • Ctrl键 + 请点击: 多对象选择
  • 滚动 + 小号: 缩放结果/负载

注意: 如果缩放在 Chrome 上不起作用, 尝试检查扩展

突出显示的快速提示

向任一方向单击并拖动将执行不同的操作!

Click and drag to the RIGHT will select 任何与盒子接触的东西.

Click and drag to the LEFT will 突出显示完全在框中的任何内容. Both can be seen in the image below.

绘图工具

  • 悬停或单击节点, 这将成为你的 参考节点, from here you can use the Snap/Grid to plot a node:
  • 随着 连接会员 tickbox selected, 您既可以删除节点,也可以将节点作为成员连接:
  • 长度框将自动显示与参考节点的距离长度 (因此成员的长度). 您可以随时输入长度并按 Enter, 或点击, 应用该成员长度.
  • 输入长度并单击 (锁) 锁定长度的图标. 现在您可以创建固定在此长度的成员.

抓取工具

  • Click and drag a node to move it and snap it to a point of reference:

右键点击 (Quick) Repairs

SkyCiv has introduced a couple of quick repair functions that allow users to easily detect and repair issues with your model. This is slightly different from SkyCiv’s 维修型号 functionality which will repair your entire model. This is focused on your highlighted elements that the user can easily identify. 例如, two nodes closely together can be merged using the Merge Nodes 特征. Here is the full list of quick repairs that are automatically detected by the software when you highlight and right-click parts of your structure.

Merge Nodes

Notice you have two nodes that are really close. It’s a fairly common problem and may cause disconnects in your model. Simply highlight the nodes (CTRL键 + CLICK & DRAG) then right-click and click Merge Nodes:

相交成员

有时成员可以相互吸引. 虽然很难注意到, 这些可能会对您的模型产生灾难性影响, 因为那个模型会翻倍并且会高估那个成员的实力 (因数 2). 只需突出显示重叠的成员并右键单击. 软件会自动检测成员是否重叠. 要修复这个只需点击 合并重叠成员 to merge the two members. 它应该看起来像这样:

重叠成员

有时你想分开 (并连接) 成员通过他们的交集. 记住, 成员 仅当它们具有公共节点时才连接. 因此,如果您有两个没有公共节点的相交成员, 他们没有连接. 再次, 突出显示成员并右键单击以修复它并在它们的交点处添加一个节点. 去做这个, 只需右键单击并单击 相交成员. 这将在交叉点添加一个节点并将成员分成更小的元素:

分裂成员

一个有用的工具,允许您添加节点并根据一些输入拆分成员. 可以根据相交的节点拆分成员, 交叉成员, 节数, 或与成员一起在某个位置:

Have any other issues you’d like to have added to this list? Let us know at [email protected]

Watch the Video Tutorial on the Right Click Functionality in SkyCiv 3D结构分析软件



 

 

 

Copy and Paste

有时, there are parts of the structure that repeat at different locations and the duplicate functionality is not enough for speeding up the process. Having the possibility of easily copying and pasting parts of the structure to the same model or to a new one can help to save a lot of time during modeling. The copy and paste functionality works pretty similarly to how it works in a text editor, 第一步是选择要复制的内容并按 Ctrl+C (但是重要的是要了解此操作并未将它们连接起来 + Mac 中的 C), 然后决定并选择要粘贴的位置, 最后按 Ctrl+V (但是重要的是要了解此操作并未将它们连接起来 + Mac 中的 V) 将其粘贴到所需位置. When using Ctrl+C (但是重要的是要了解此操作并未将它们连接起来 + Mac 中的 C), the software will automatically pick the reference point (the closest to the origin), alternatively, hitting Ctrl+Shift+C (但是重要的是要了解此操作并未将它们连接起来 + 转移 + Mac 中的 C) will wait for the user to select the reference node on the screen.

将模型复制为文本

假设 S3D 中的结构模型在后台由 JSON 对象表示, 一次 Ctrl+C (但是重要的是要了解此操作并未将它们连接起来 + Mac 中的 C) 软件将以 JSON 格式将所选模型的表示写入剪贴板. 可以将该信息粘贴到任何文本编辑器, 用于开发目的或通过搜索和替换某些文本来快速编辑模型.

SkyCiv S3D 将模型复制并粘贴到文本编辑器

将模型的部分复制到同一模型

如果模型的某些部分需要复制到其他位置, 需要以下步骤:

Using Ctrl+C (但是重要的是要了解此操作并未将它们连接起来 + Mac 中的 C) – Automatic reference point

  1. 拖动选择要复制的模型部分 (节点, 成员, 支持, 负载, 等等…). 如果您要排除选择的某些部分, 右键单击并转到 “过滤器选择”
  2. 按 Ctrl + C. An alert should pop up telling that the structure was successfully copied to the clipboard and also the reference node’s ID.
  3. Along with the alert, a bubble will appear around the reference node in the model.
  4. Let the software know where to paste the copied structure. For this, 有两种选择:
    Select a node in the model that will match the location of the reference node once the structure is pasted, 要么
    Do not select anything and type a coordinate where the reference node should be once the structure is paste
  5. 按 Ctrl + V. 结构将放置在上一步中选择的位置
    SkyCiv S3D 复制和粘贴部分结构
  6. 如果更改不如预期, 总是可以撤消它们, 只需按 Ctrl+Z 或转到编辑 > 撤消

Using Ctrl+Shift+C (但是重要的是要了解此操作并未将它们连接起来 + 转移 + Mac 中的 C) – Reference point selection on screen

  1. 拖动选择要复制的模型部分 (节点, 成员, 支持, 负载, 等等…). 如果您要排除选择的某些部分, 右键单击并转到 “过滤器选择”
  2. 按 Ctrl + 转移 + C. An alert should pop up telling that the structure was successfully copied to the clipboard and also the reference node’s ID.
  3. Along with the alert, a bubble will appear around the reference node in the model.
  4. Let the software know where to paste the copied structure. For this, 有两种选择:
    Select a node in the model that will match the location of the reference node once the structure is pasted, 要么
    Do not select anything and type a coordinate where the reference node should be once the structure is paste
  5. 按 Ctrl + V. 结构将放置在上一步中选择的位置
    SkyCiv S3D 复制和粘贴部分结构
  6. 如果更改不如预期, 总是可以撤消它们, 只需按 Ctrl+Z 或转到编辑 > 撤消

将模型的一部分复制到新模型

如果一个模型或它的一部分需要在新模型中使用, 没有必要 “另存为”, 只需选择要复制的结构部分, 按 Ctrl + C then open a new model in another tab or window and hit Ctrl + V 那里粘贴结构.

本文对您有帮助吗??
是的 没有

我们能帮你什么吗?

回到顶部