Documentación SkyCiv

Su guía para el software SkyCiv: tutoriales, guías prácticas y artículos técnicos

SkyCiv para Excel

Complemento de Excel para el diseño y modelado de análisis estructural SkyCiv API V3

Introducción

Excel es un software de hoja de cálculo icónico que se utiliza ampliamente en ciencia e ingeniería.. En ingeniería estructural el poder de Excel, especialmente en conjunción con macros, es conocido por su accesibilidad, flexibilidad y potencia informática. SkyCiv para Excel abre nuevos caminos en la integración de software de ingeniería al proporcionar a los usuarios un conjunto completo de herramientas de diseño y análisis estructural desde Microsoft Excel. También vale la pena señalar que el complemento es una aplicación incorporada, no solo una hoja o macro VBA.

Esta página de documentación cubre los siguientes aspectos del complemento SkyCiv Excel:

Empezando

Instalación

Para instalar SkyCiv para Excel, navegar hasta el Mercado de Microsoft y haga clic en “Consiguelo ahora”. Siga las instrucciones de instalación y una vez instalado, debería ver la pestaña SkyCiv en el cliente de Excel. Alternativamente, puede instalar este complemento directamente desde Excel (simplemente busque en AppSource SkyCiv):

Una vez instalada, haga clic en la pestaña y se le presentará una nueva cinta de herramientas como se ve a continuación.

Herramientas disponibles & Funcionalidad

Aquí hay una breve explicación de cada botón de la cinta de izquierda a derecha., agrupados como aparecen.

  • General
    • Configuraciones: Aquí es donde ingresas tu Credenciales API de SkyCiv. Estos son necesarios para permitirle ejecutar análisis, diseños para, Calculadoras de diseño rápido, acceder a las bases de datos de secciones y materiales, abrir o guardar modelos y abrirlos en S3D. Esto no es necesario para construir su modelo o para verlo en el renderizador..
    • Abierto: Aquí es donde puede acceder a todos sus modelos SkyCiv, incluso los creados en el sitio web. Tras la selección, el modelo se importará al libro de trabajo. Si no ha seleccionado el botón Configuración antes de seleccionar un modelo, esto se hará automáticamente para que usted cree las tablas. Tenga en cuenta que esto reemplazará cualquier modelo existente en el libro de trabajo..
    • Guarda: Aquí es donde puede guardar su modelo en la plataforma SkyCiv.
    • S3D: Esto abrirá un panel donde al hacer clic “Abrir en S3D” guardará su modelo de Excel con el nombre 'temp-excel-plugin’ y luego ábrelo en el navegador. Permitir 10 segundos más o menos para que esta acción se complete.
  • Preparar
    • Preparar: Esto creará tablas vacías que le permitirán construir un modelo desde cero..
    • compuestas: Esto presentará una interfaz donde puede seleccionar varias secciones de miembros e insertarlas en una fila existente de la tabla de secciones., elegido por su ID.
    • Materiales: Esto presentará una interfaz donde podrá seleccionar varios materiales e insertarlos en una fila existente de la tabla de materiales., elegido por su ID.
  • Herramientas
    • Analizar: Aquí es donde puede ejecutar un análisis en su modelo. Los resultados se proporcionarán en nuevas hojas..
    • Diseño: Aquí es donde puede ejecutar un diseño en su modelo.. Los resultados se proporcionarán en nuevas hojas..
    • Diseño rápido: Aquí es donde puede ejecutar las calculadoras SkyCiv Quick Design, independientemente de tu modelo. Ver el Diseño rápido sección a continuación.
  • renderizador
    • Hacer: Esto abrirá el renderizador SkyCiv dentro de Excel. Verá la actualización de su modelo en vivo en el renderizador a medida que se edita.
    • Muestras: Esto mostrará un conjunto de modelos 3D de muestra que puede cargar rápidamente en su libro de trabajo.. Tenga en cuenta que esto reemplazará cualquier modelo existente en el libro de trabajo..
  • Información
    • Acerca de: Este botón abrirá esta página en el navegador predeterminado.
    • Docs: Este botón abrirá los documentos de la API de SkyCiv en el navegador predeterminado. Aquí es donde puede ver cuál es la entrada permitida para cada columna de la hoja de trabajo SkyCiv.

Modelado

La mejor manera de comenzar a modelar es haciendo clic en el botón Configuración. (Las unidades métricas se utilizan por defecto., puedes cambiar esto en Configuración). La hoja de trabajo SkyCiv se creará con varias tablas. Expanda las secciones de nodos y miembros haciendo clic en el pequeño + botones encima de las etiquetas de las columnas. Ahora haga clic en el botón Renderizar en la cinta de SkyCiv y verá el panel de tareas Renderer abierto en el lado derecho del libro de trabajo.

La identificación’ La columna de cualquier tabla debe comenzar en 1 y aumentar – así que entra 1,0,0,0 en la primera fila de la tabla de nodos. Esto crea un nodo con un ID de 1 en la x,y,coordenadas z 0,0,0. Ahora en la siguiente fila, agregar otro nodo: 2,0,1,0. Esto creará un nodo con un ID de 2 a 0,1,0. El renderizador ahora debería mostrar dos nodos, uno en el origen, y otro encima. Si no ve los dos nodos, verifique que ambas filas estén dentro de la tabla de nodos arrastrando la pequeña flecha en la parte inferior derecha de la tabla para incluir ambas filas. Esto es lo que deberías tener hasta ahora.

Ahora agreguemos un miembro. En los miembros’ mesa, cree un miembro nuevo agregando "1’ para el ID en la primera fila de los miembros’ mesa. Establecer "nodo_A’ a 1, "Nodo_B’ a 2 y proporcione un ID de sección de "1". El ID de sección corresponde a la fila en la tabla de secciones con ese ID. Tenga en cuenta que en esta etapa, el renderizador solo representará secciones como cuadrados sólidos. Ahora sus tablas deberían verse como las siguientes.

Otra excelente manera de familiarizarse con el complemento es abrir un modelo básico mediante el botón Abrir e inspeccionar cómo se ve el modelo cuando se representa mediante tablas.

Tenga en cuenta que las entradas deben ser exactas. Para ver las entradas permitidas para cualquier columna, seleccione su encabezado (Las columnas con opciones fijas también proporcionan un menú desplegable.) o haga clic en el botón Documentos y accederá a la página de documentación de API para crear un modelo.. Esto también se aplica a los encabezados de las tablas., no cambies estos.

3D

Una vez autenticado usando la pestaña Configuración, puede ejecutar un análisis a través de la pestaña Analizar. Puedes elegir el tipo de análisis y, si su modelo tiene dos o más combinaciones de carga, filtrar qué resultados devolver. Tenga en cuenta que incluir todos los casos y combinaciones es una gran cantidad de datos! Para aumentar la velocidad, solo selecciona los que necesitas.

Una vez completado, Se crearán nuevas hojas de trabajo con el nombre del caso de carga y la combinación y cada hoja contendrá todos los datos de los resultados.. Hemos creado una sección de Búsqueda de resultados para ayudarlo a verificar rápidamente los datos en todas las hojas de resultados..

SkyCiv para Excel - 3D

Diseño

Una vez autenticado usando la pestaña Configuración, puede ejecutar comprobaciones de diseño a través de la pestaña Diseño. Elija el código de diseño correcto para su modelo y haga clic en diseño. Una vez completado, los resultados del diseño se agregarán a una nueva hoja llamada “Resultados de diseño”. El panel de tareas de Diseño proporcionará un resumen de todo el diseño y también una sección para inspeccionar rápidamente a cualquier miembro e incluso descargar un informe de diseño para el miembro.. Usando el modelo del análisis anterior, la siguiente imagen es el resultado del diseño. El AISC 360-16 LRFD El código se seleccionó ya que el modelo se creó utilizando secciones AISC..

SkyCiv para Excel - Diseño

Actualmente, el complemento de Excel admite las siguientes comprobaciones de códigos de diseño:

  • Acero: AISC 360-16 & 360-10 (ASD, LRFD), Eurocódigo 3 (EN 1993-1-1:2005), BS 5950-1:2000, AS 4100-1998 & 2020, Nueva Zelanda 3404-1997, CSA S16-14, ES 800-2007 ONG & ES 800-1984 WSM
  • Acero conformado en frío: AISI S100-16 (ASD, LRFD, LSD), AISI S100-12 (ASD, LRFD), Eurocódigo 3 (EN 1993-1-3:2006), AS / NZS 4600-2005 & 2018
  • Madera: NDS 2018 (ASD, LRFD), AS 1720-2010

Diseño rápido

Además de las funciones S3D, El complemento de Excel también le brinda acceso a la amplia gama de calculadoras de análisis y diseño para múltiples códigos internacionales disponibles en el Diseño rápido SkyCiv Biblioteca. Esto le permite ejecutar estas herramientas por lotes y completar múltiples comprobaciones de diseño en minutos.. Nota: esta característica es independiente del modelo estructural S3D utilizado por el resto del complemento.

Una vez autenticado, Puedes acceder a esta herramienta a través de la pestaña Diseño rápido.. Allí, puede seleccionar la calculadora que desee e incorporarla al libro de trabajo utilizando el “Insertar tabla de entrada” ,, con la opción de elegir el sistema de unidades (si es aplicable). Esto creará una hoja llamada “Entrada de diseño rápido” con una tabla donde las entradas de la calculadora son las columnas y cada fila es una entrada separada, similar al “Ejecución por lotes” característica en el sitio web de Quick Design. La tabla se crea con una fila de ejemplo.; utilizar el “Agregar fila con valores predeterminados” botón para agregar cada fila adicional que necesite. Tenga en cuenta que el libro maneja solo una calculadora a la vez: insertando otra calculadora, o cambiar el sistema de la unidad después de insertarla, reemplazará la tabla existente, y cualquier valor que ya haya ingresado se perderá.

tomemos el “AISC 360-22 Capacidad del grupo de soldadura” calculadora como ejemplo. Cuando su tabla está insertada en unidades imperiales, se ve así:

SkyCiv para Excel - Tabla de entrada de diseño rápido

Tenga en cuenta que para calculadoras complejas como ésta, que incluyen tablas como parte de sus entradas (es decir, subtablas, que en este caso son “Soldaduras horizontales” y “Soldaduras verticales”), Se crea una hoja adicional para cada subtabla., con “QD” como prefijo. Estas tablas incluyen una “configuración” columna utilizada para agrupar configuraciones. Por ejemplo, en la imagen, todas las filas con un valor de 1 en esta columna pertenecen a la misma configuración de soldadura vertical, y así. La mesa principal en “Entrada de diseño rápido” incluye una columna para cada una de estas subtablas, donde debe ingresar el ID de la configuración coincidente.

SkyCiv para Excel - Subtabla de diseño rápido

Una vez que todas las entradas estén completas, puedes ejecutarlos haciendo clic en el “Ejecutar lote” ,. Esto creará una nueva hoja llamada “Salida de diseño rápido” con los resultados de cada fila, incluyendo un enlace al informe de cálculo para cada entrada. Tenga en cuenta que estos enlaces son temporales y dejará de funcionar después de un tiempo. también, cada ejecución reemplaza el “Salida de diseño rápido” sábana, así que si quieres mantener los resultados anteriores, cambie el nombre o copie esa hoja antes de volver a ejecutarla.

SkyCiv para Excel - Resultados de diseño rápidos

Apoyo

Necesito ayuda en el camino? No dude en enviarnos un correo electrónico a [email protected] oa través de nuestro chat en vivo una vez que haya iniciado sesión en la plataforma. Para obtener información sobre nuestros términos y condiciones para esta aplicación, visita nuestro Términos y condiciones página de referencia.

¿Cómo podemos ayudar??

×

Actualizado septiembre 26, 2026

Todavía estancado? Contáctanos

Ve arriba